TIBCO Spotfire Connectors System Requirements



TIBCO Spotfire Connector for Amazon Redshift
TIBCO Spotfire Connector for Apache Spark SQL
TIBCO Spotfire Connector for Cloudera Hive
TIBCO Spotfire Connector for Cloudera Impala
TIBCO Spotfire Connector for Cisco ("Composite") Information Server
TIBCO Spotfire Connector for Hortonworks
TIBCO Spotfire Connector for HP Vertica
TIBCO Spotfire Connector for IBM DB2
TIBCO Spotfire Connector for IBM Netezza
TIBCO Spotfire Connector for Microsoft SQL Server
TIBCO Spotfire Connector for Microsoft SQL Server Analysis Services
TIBCO Spotfire Connector for OData
TIBCO Spotfire Connector for Oracle
TIBCO Spotfire Connector for Oracle Essbase
TIBCO Spotfire Connector for Oracle MySQL
TIBCO Spotfire Connector for Pivotal Greenplum
TIBCO Spotfire Connector for Pivotal HAWQ
TIBCO Spotfire Connector for PostgreSQL (and Amazon Redshift)
TIBCO Spotfire Connector for SAP HANA
TIBCO Spotfire Connector for SAP NetWeaver Business Warehouse
TIBCO Spotfire Connector for Teradata
TIBCO Spotfire Connector for Teradata Aster


TIBCO Spotfire Connector for Amazon Redshift
Version: Spotfire Cloud version
Category Requirement
Data Source Amazon Redshift
Driver Any of the following:
  • Amazon Redshift ODBC Driver (recommended)
  • psqlODBC 9.x

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Authentication Methods Username and Password (SSL)
SSL Support Yes
Version: 4.0
Category Requirement
Data Source Amazon Redshift
Driver psqlODBC 9.x

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Authentication Methods Username and Password (SSL)
SSL Support Yes


TIBCO Spotfire Connector for Apache Spark SQL
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • Apache Spark SQL 1.4.0 or later

NOTE: Cloudera currently does not support Spark SQL in a production environment
NOTE: Hortonworks currently provides Spark SQL as a technical preview
Driver Any of the following:
  • TIBCO Spotfire ODBC Driver for Apache Spark SQL, Version 1.0.8 or later
  • Databricks ODBC Driver for Apache Spark SQL, Version 1.0.8 or later
  • Simba ODBC Driver for Apache Spark SQL, Version 1.0.8 or later

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Authentication Methods Anonymous
Username
Kerberos
LDAP


TIBCO Spotfire Connector for Cloudera Hive
Version: Spotfire Cloud Version
Category Requirement
Data Source Any of the following:
  • Cloudera CDH4.x
  • Cloudera CDH5.x
  • Cloudera Hive on Spark, Tez or MapReduce (where applicable)
HiveServer HiveServer2
Driver Cloudera ODBC Driver for Apache Hive, Version 2.5.5 or higher

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Authentication Methods Anonymous
Username
Kerberos
LDAP
LDAP (SSL)
Version: 4.0
Category Requirement
Data Source Any of the following:
  • Cloudera CDH4.x
  • Cloudera CDH5.x
  • Cloudera Hive on Spark, Tez or MapReduce (where applicable)
HiveServer HiveServer2
Driver Cloudera ODBC Driver for Apache Hive, Version 2.5.5 or higher

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Authentication Methods Anonymous
Username
Kerberos
LDAP
LDAP (SSL)
Version: 2.2
Category Requirement
Data Source Any of the following:
  • Cloudera CDH4.x
  • Cloudera CDH5.x
HiveServer HiveServer2
Driver Cloudera ODBC Driver for Apache Hive, Version 2.5.5, 2.5.9, 2.5.10 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Authentication Methods Anonymous
Username
Kerberos
LDAP
LDAP (SSL)
Version: 2.1
Category Requirement
Data Source Any of the following:
  • Cloudera CDH4.x
  • Cloudera CDH5.x
HiveServer HiveServer2
Driver Cloudera ODBC Driver for Apache Hive, Version 2.5.5, 2.5.9, 2.5.10 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Authentication Methods User name only authentication is currently supported for this connector.
Version: 2.0
Category Requirement
Data Source Any of the following:
  • Cloudera CDH4.x
  • Cloudera CDH5.x
HiveServer HiveServer2
Driver Cloudera Hive ODBC Driver version 2.5.5 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Authentication Methods User name only authentication is currently supported for this connector.
Version: 1.0
Category Requirement
Data Source Any of the following:
  • Cloudera CDH4.x
  • Cloudera CDH5.x
HiveServer HiveServer2
Driver Cloudera Hive ODBC Driver version 2.5.0 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0
Authentication Methods User name only authentication is currently supported for this connector.


TIBCO Spotfire Connector for Cloudera Impala
Version: Spotfire Cloud version
Category Requirement
Data Source Any Cloudera Impala version (1.2.2 or higher) that is supported by Cloudera for use with the Hadoop distributions listed below. For more information on this, please refer to Cloudera's Product Compatibility Matrix.
Hadoop distribution Any of the following:
  • Cloudera CDH4.x
  • Cloudera CDH5.x
HiveServer HiveServer2
Driver Cloudera Impala ODBC Driver, Version 2.5.2 or higher

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Authentication Methods Anonymous
Username
Kerberos
LDAP
LDAP (SSL)
Version: 4.0
Category Requirement
Data Source Any Cloudera Impala version (1.2.2 or higher) that is supported by Cloudera for use with the Hadoop distributions listed below. For more information on this, please refer to Cloudera's Product Compatibility Matrix.
Hadoop distribution Any of the following:
  • Cloudera CDH4.x
  • Cloudera CDH5.x
HiveServer HiveServer2
Driver Cloudera Impala ODBC Driver, Version 2.5.2 or higher

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Authentication Methods Anonymous
Username
Kerberos
LDAP
LDAP (SSL)
Version: 2.2
Category Requirement
Data Source Any Cloudera Impala version (1.2.2 or higher) that is supported by Cloudera for use with the Hadoop distributions listed below. For more information on this, please refer to Cloudera's Product Compatibility Matrix.
Hadoop distribution Any of the following:
  • Cloudera CDH4.x
  • Cloudera CDH5.x
HiveServer HiveServer2
Driver Cloudera Impala ODBC Driver version 2.5.2, 2.5.15, 2.5.17 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Authentication Methods Anonymous
Username
Kerberos
LDAP
LDAP (SSL)
Version: 2.1
Category Requirement
Data Source Any Cloudera Impala version (1.2.2 or higher) that is supported by Cloudera for use with the Hadoop distributions listed below. For more information on this, please refer to Cloudera's Product Compatibility Matrix.
Hadoop distribution Any of the following:
  • Cloudera CDH4.x
  • Cloudera CDH5.x
HiveServer HiveServer2
Driver Cloudera Impala ODBC Driver version 2.5.2, 2.5.15, 2.5.17 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Authentication Methods User name only authentication is currently supported for this connector.
Version: 2.0
Category Requirement
Data Source Any Cloudera Impala version (1.2.2 or higher) that is supported by Cloudera for use with the Hadoop distributions listed below. For more information on this, please refer to Cloudera's Product Compatibility Matrix.
Hadoop distribution Any of the following:
  • Cloudera CDH4.x
  • Cloudera CDH5.x
HiveServer HiveServer2
Driver Cloudera Impala ODBC Driver version 2.5.2 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Authentication Methods User name only authentication is currently supported for this connector.
Version: 1.0
Category Requirement
Data Source Any Cloudera Impala version (1.2.2 or higher) that is supported by Cloudera for use with the Hadoop distributions listed below. For more information on this, please refer to Cloudera's Product Compatibility Matrix.
Hadoop distribution
  • Cloudera CDH4.x
HiveServer HiveServer2
Driver Cloudera Impala ODBC Driver version 2.5.2 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0
Authentication Methods User name only authentication is currently supported for this connector.


TIBCO Spotfire Connector for Cisco ("Composite") Information Server
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • Cisco ("Composite") Information Server 6.1.x, 6.2.x
  • TIBCO Spotfire Advanced Data Services 6.1 (corresponding to Cisco ("Composite") Information Server 6.1)
Driver The driver must be installed on the machine running the data connector.

NOTE: The driver can be downloaded from Knowledge Base article 43318, available in TIBCO Support Central.
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Any of the following:
  • Cisco ("Composite") Information Server 6.1.x, 6.2.x
  • TIBCO Spotfire Advanced Data Services 6.1 (corresponding to Cisco ("Composite") Information Server 6.1)
Driver The driver must be installed on the machine running the data connector.

NOTE: The driver can be downloaded from Knowledge Base article 43318, available in TIBCO Support Central.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Version: 3.2
Category Requirement
Data Source Any of the following:
  • Cisco ("Composite") Information Server 6.1.x, 6.2.x
  • TIBCO Spotfire Advanced Data Services 6.1 (corresponding to Cisco ("Composite") Information Server 6.1)
Driver The required driver is included out-of-the-box in the Spotfire installation.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 3.1
Category Requirement
Data Source Any of the following:
  • Cisco ("Composite") Information Server 6.1.x, 6.2.x
  • TIBCO Spotfire Advanced Data Services 6.1 (corresponding to Cisco ("Composite") Information Server 6.1)
Driver The required driver is included out-of-the-box in the Spotfire installation.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 3.0
Category Requirement
Data Source Any of the following:
  • Cisco ("Composite") Information Server 6.1.x, 6.2.x
  • TIBCO Spotfire Advanced Data Services 6.1 (corresponding to Cisco ("Composite") Information Server 6.1)
Driver The required driver is included out-of-the-box in the Spotfire installation.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 2.0
Category Requirement
Data Source Any of the following:
  • Cisco ("Composite") Information Server 6.1.x, 6.2.x
  • TIBCO Spotfire Advanced Data Services 6.1 (corresponding to Cisco ("Composite") Information Server 6.1)
Driver The required driver is included out-of-the-box in the Spotfire installation.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0
Version: 1.0
Category Requirement
Data Source Any of the following:
  • Cisco ("Composite") Information Server 6.1.x, 6.2.x
  • TIBCO Spotfire Advanced Data Services 6.1 (corresponding to Cisco ("Composite") Information Server 6.1)
Driver The required driver is included out-of-the-box in the Spotfire installation.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 5.5
  • TIBCO Spotfire Web Player 5.5
  • TIBCO Spotfire Automation Services 5.5


TIBCO Spotfire Connector for Hortonworks
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • Hortonworks Data Platform (HDP) 1.3.8, 2.0, 2.1.x, 2.2.x
  • Apache Hive on Spark, Tez or MapReduce (where applicable)
HiveServer HiveServer2
Driver Hortonworks ODBC Driver version 1.2 or higher

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Authentication Methods No Authentication
Kerberos
Username
Username and Password
Username and Password (SSL)
Version: 4.0
Category Requirement
Data Source Any of the following:
  • Hortonworks Data Platform (HDP) 1.3.8, 2.0, 2.1.x, 2.2.x
  • Apache Hive on Spark, Tez or MapReduce (where applicable)
HiveServer HiveServer2
Driver Hortonworks ODBC Driver version 1.2 or higher

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Authentication Methods No Authentication
Kerberos
Username
Username and Password
Username and Password (SSL)
Version: 2.2
Category Requirement
Data Source Any of the following:
  • Hortonworks Data Platform (HDP) 1.3.8, 2.0, 2.1.x
  • Apache Hive
HiveServer HiveServer2
Driver Hortonworks ODBC Driver version 1.2 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Authentication Methods Anonymous
Username
Version: 2.1
Category Requirement
Data Source Any of the following:
  • Hortonworks Data Platform (HDP) 1.3.8, 2.0
Driver Hortonworks ODBC Driver version 1.2 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Authentication Methods Anonymous
Username
Version: 2.0
Category Requirement
Data Source Any of the following:
  • Hortonworks Data Platform (HDP) 1.3.8, 2.0
Driver Hortonworks ODBC Driver version 1.2 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Authentication Methods Anonymous
Username
Version: 1.0
Category Requirement
Data Source Any of the following:
  • Hortonworks Data Platform (HDP) 1.3.8, 2.0
Driver Hortonworks ODBC Driver version 1.2 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0
Authentication Methods Anonymous
Username


TIBCO Spotfire Connector for HP Vertica
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • HP Vertica 6.0, 6.1, 7
Driver HP Vertica ADO.NET driver 6.x, 7.0.x

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Any of the following:
  • HP Vertica 6.0, 6.1, 7
Driver HP Vertica ADO.NET driver 6.x, 7.0.x

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Version: 3.1
Category Requirement
Data Source Any of the following:
  • HP Vertica 6.0, 6.1, 7
Driver HP Vertica ADO.NET driver 6.x, 7.0.x

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 3.0
Category Requirement
Data Source Any of the following:
  • HP Vertica 6.0, 6.1, 7
Driver HP Vertica ADO.NET driver 6.x, 7.0.x

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 2.0
Category Requirement
Data Source Any of the following:
  • HP Vertica 6.0, 6.1
Driver HP Vertica ADO.NET driver 6.0, 6.1

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0


TIBCO Spotfire Connector for IBM DB2
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • IBM DB2 LUW 9.x, 10.x (LUW = Linux, Unix, Windows)
Driver IBM DB2 ODBC driver 10.5

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Any of the following:
  • IBM DB2 LUW 9.x, 10.x (LUW = Linux, Unix, Windows)
Driver IBM DB2 ODBC driver 10.5

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Version: 1.2
Category Requirement
Data Source Any of the following:
  • IBM DB2 LUW 9.x, 10.x (LUW = Linux, Unix, Windows)
Driver IBM DB2 ODBC driver 10.5

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 1.1
Category Requirement
Data Source Any of the following:
  • IBM DB2 LUW 9.x, 10.x (LUW = Linux, Unix, Windows)
Driver IBM DB2 ODBC driver 10.5

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 1.0
Category Requirement
Data Source Any of the following:
  • IBM DB2 LUW 9.x, 10.x (LUW = Linux, Unix, Windows)
Driver IBM DB2 ODBC driver 10.5

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5


TIBCO Spotfire Connector for IBM Netezza
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following
  • IBM Netezza NPS 6, 7
Driver IBM Netezza ODBC Driver version 7.0.0.x

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Any of the following
  • IBM Netezza NPS 6, 7
Driver IBM Netezza ODBC Driver version 7.0.0.x

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Version: 3.1
Category Requirement
Data Source Any of the following
  • IBM Netezza NPS 6, 7
Driver IBM Netezza ODBC Driver version 7.0.0.x (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 3.0
Category Requirement
Data Source Any of the following
  • IBM Netezza NPS 6, 7
Driver IBM Netezza ODBC Driver version 7.0.0.2 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 2.0
Category Requirement
Data Source Any of the following
  • IBM Netezza NPS 6, 7
Driver IBM Netezza ODBC Driver version 7.0.0.2 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0
Version: 1.0
Category Requirement
Data Source Any of the following
  • IBM Netezza NPS 6, 7
Driver IBM Netezza ODBC Driver version 7.0.0.2 (32- and 64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 5.5
  • TIBCO Spotfire Web Player 5.5
  • TIBCO Spotfire Automation Services 5.5


TIBCO Spotfire Connector for Microsoft SQL Server
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2008 R2
Driver The required driver is included in Microsoft.NET - no need for a separate install.
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Any of the following:
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2008 R2
Driver The required driver is included in Microsoft.NET - no need for a separate install.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Version: 3.1
Category Requirement
Data Source Any of the following:
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2008 R2
Driver The required driver is included in Microsoft.NET - no need for a separate install.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 3.0
Category Requirement
Data Source Any of the following:
  • Microsoft SQL Server 2014
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2008 R2
Driver The required driver is included in Microsoft.NET - no need for a separate install.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 2.0
Category Requirement
Data Source Any of the following:
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2008 R2
Driver The required driver is included in Microsoft.NET - no need for a separate install.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0
Version: 1.0
Category Requirement
Data Source Any of the following:
  • Microsoft SQL Server 2012
  • Microsoft SQL Server 2008 R2
Driver The required driver is included in Microsoft.NET - no need for a separate install.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 5.5
  • TIBCO Spotfire Web Player 5.5
  • TIBCO Spotfire Automation Services 5.5


TIBCO Spotfire Connector for Microsoft SQL Server Analysis Services
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • Microsoft SQL Server Analysis Services 2014 in Multidimensional or Tabular Mode
  • Microsoft SQL Server Analysis Services 2012 in Multidimensional or Tabular Mode
  • Microsoft SQL Server Analysis Services 2008 R2
Driver Any of the following:
  • Microsoft ADOMD.NET driver for SQL Server 2014
  • Microsoft ADOMD.NET driver for SQL Server 2012
  • Microsoft ADOMD.NET driver for SQL Server 2008 R2

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Any of the following:
  • Microsoft SQL Server Analysis Services 2014 in Multidimensional or Tabular Mode
  • Microsoft SQL Server Analysis Services 2012 in Multidimensional or Tabular Mode
  • Microsoft SQL Server Analysis Services 2008 R2
Driver Any of the following:
  • Microsoft ADOMD.NET driver for SQL Server 2014
  • Microsoft ADOMD.NET driver for SQL Server 2012
  • Microsoft ADOMD.NET driver for SQL Server 2008 R2

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Version: 3.1
Category Requirement
Data Source Any of the following:
  • Microsoft SQL Server Analysis Services 2014 in Multidimensional or Tabular Mode
  • Microsoft SQL Server Analysis Services 2012 in Multidimensional or Tabular Mode
  • Microsoft SQL Server Analysis Services 2008 R2
Driver Any of the following:
  • Microsoft ADOMD.NET driver for SQL Server 2014
  • Microsoft ADOMD.NET driver for SQL Server 2012
  • Microsoft ADOMD.NET driver for SQL Server 2008 R2

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 3.0
Category Requirement
Data Source Any of the following:
  • Microsoft SQL Server Analysis Services 2014 in Multidimensional or Tabular Mode
  • Microsoft SQL Server Analysis Services 2012 in Multidimensional or Tabular Mode
  • Microsoft SQL Server Analysis Services 2008 R2
Driver Any of the following:
  • Microsoft ADOMD.NET driver for SQL Server 2014
  • Microsoft ADOMD.NET driver for SQL Server 2012
  • Microsoft ADOMD.NET driver for SQL Server 2008 R2

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 2.0
Category Requirement
Data Source Any of the following:
  • Microsoft SQL Server Analysis Services 2012 in Multidimensional or Tabular Mode
  • Microsoft SQL Server Analysis Services 2008 R2
Driver Any of the following:
  • Microsoft ADOMD.NET driver for SQL Server 2012
  • Microsoft ADOMD.NET driver for SQL Server 2008 R2

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0
Version: 1.0
Category Requirement
Data Source Any of the following:
  • Microsoft SQL Server Analysis Services 2012 in Multidimensional or Tabular Mode
  • Microsoft SQL Server Analysis Services 2008 R2
Driver Any of the following:
  • Microsoft ADOMD.NET driver for SQL Server 2012
  • Microsoft ADOMD.NET driver for SQL Server 2008 R2

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 5.5
  • TIBCO Spotfire Web Player 5.5
  • TIBCO Spotfire Automation Services 5.5


TIBCO Spotfire Connector for OData
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • OData 1,2,3,4
Driver There is no need for a driver for this connector.
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Authentication Methods Any of the following:
  • Anonymous
  • Username and Password (Basic)
  • Windows Authentication
  • Microsoft Azure Marketplace
SSL Support Yes
Version: 4.0
Category Requirement
Data Source Any of the following:
  • OData 1,2,3,4
Driver There is no need for a driver for this connector.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Authentication Methods Any of the following:
  • Anonymous
  • Username and Password (Basic)
  • Windows Authentication
  • Microsoft Azure Marketplace
SSL Support Yes


TIBCO Spotfire Connector for Oracle
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • Oracle 11gR1, 11gR2, 12c
  • Oracle Exadata X2 (11gR2, 12c)
Driver Any of the following:
  • ODAC (ODP.NET) 12c
  • ODAC (ODP.NET) 11.2.0.x (11.2.0.0 or higher)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Any of the following:
  • Oracle 11gR1, 11gR2, 12c
  • Oracle Exadata X2 (11gR2, 12c)
Driver Any of the following:
  • ODAC (ODP.NET) 12c
  • ODAC (ODP.NET) 11.2.0.x (11.2.0.0 or higher)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Version: 3.1
Category Requirement
Data Source Any of the following:
  • Oracle 11gR1, 11gR2, 12c
  • Oracle Exadata X2 (11gR2, 12c)
Driver Any of the following:
  • ODAC (ODP.NET) 12c
  • ODAC (ODP.NET) 11.2.0.x (11.2.0.0 or higher)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 3.0
Category Requirement
Data Source Any of the following:
  • Oracle 11gR1, 11gR2, 12c
  • Oracle Exadata X2 (11gR2, 12c)
Driver Any of the following:
  • ODAC (ODP.NET) 12c
  • ODAC (ODP.NET) 11.2.0.x (11.2.0.0 or higher)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 2.0
Category Requirement
Data Source Any of the following:
  • Oracle 11gR1, 11gR2
  • Oracle Exadata X2 (Oracle 11gR2)
Driver Any of the following:
  • ODAC (ODP.NET) 12c
  • ODAC (ODP.NET) 11.2.0.x (11.2.0.0 or higher)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0
Version: 1.0
Category Requirement
Data Source Any of the following:
  • Oracle 11gR1, 11gR2
  • Oracle Exadata X2 (Oracle 11gR2)
Driver Any of the following:
  • ODAC (ODP.NET) 12c
  • ODAC (ODP.NET) 11.2.0.x (11.2.0.0 or higher)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 5.5
  • TIBCO Spotfire Web Player 5.5
  • TIBCO Spotfire Automation Services 5.5


TIBCO Spotfire Oracle Essbase Connector
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • Oracle Essbase 9.3, 11.1
Driver Oracle Enterprise Performance Management System (11.1.2.3.0) Media Pack for Microsoft x64

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Any of the following:
  • Oracle Essbase 9.3, 11.1
Driver Oracle Enterprise Performance Management System (11.1.2.3.0) Media Pack for Microsoft x64

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Version: 3.2
Category Requirement
Data Source Any of the following:
  • Oracle Essbase 9.3, 11.1
Driver Oracle Enterprise Performance Management System (11.1.2.3.0) Media Pack for Microsoft x64 (64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 3.1
Category Requirement
Data Source Any of the following:
  • Oracle Essbase 9.3, 11.1
Driver Oracle Enterprise Performance Management System (11.1.2.3.0) Media Pack for Microsoft x64 (64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 3.0
Category Requirement
Data Source Any of the following:
  • Oracle Essbase 9.3, 11.1
Driver Oracle Enterprise Performance Management System (11.1.2.3.0) Media Pack for Microsoft x64 (64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 2.0
Category Requirement
Data Source Any of the following:
  • Oracle Essbase 9.3, 11.1
Driver Oracle Enterprise Performance Management System (11.1.2.3.0) Media Pack for Microsoft x64 (64-bit)

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0


TIBCO Spotfire Connector for Oracle MySQL
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • Oracle MySQL 5.1, 5.5, 5.6
Driver Any of the following:
  • Oracle MySQL Connector/Net 6.6.5 to 6.8.3

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Any of the following:
  • Oracle MySQL 5.1, 5.5, 5.6
Driver Any of the following:
  • Oracle MySQL Connector/Net 6.6.5 to 6.8.3

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Version: 3.1
Category Requirement
Data Source Any of the following:
  • Oracle MySQL 5.1, 5.5, 5.6
Driver Any of the following:
  • Oracle MySQL Connector/Net 6.6.5 to 6.8.3

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 3.0
Category Requirement
Data Source Any of the following:
  • Oracle MySQL 5.1, 5.5, 5.6
Driver Any of the following:
  • Oracle MySQL Connector/Net 6.6.5 to 6.8.3

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 2.0
Category Requirement
Data Source Any of the following:
  • Oracle MySQL 5.1, 5.5, 5.6
Driver Any of the following:
  • Oracle MySQL Connector/Net 6.6.5 to 6.8.3

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0
Version: 1.0
Category Requirement
Data Source Any of the following:
  • Oracle MySQL 5.1, 5.5, 5.6
Driver Any of the following:
  • Oracle MySQL Connector/Net 6.6.5 to 6.8.3

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 5.5
  • TIBCO Spotfire Web Player 5.5
  • TIBCO Spotfire Automation Services 5.5


TIBCO Spotfire Connector for Pivotal Greenplum
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • Greenplum Database 4.1, 4.2, 4.3
  • HAWQ
Driver Any of the following:
  • PsqlODBC 9.x
  • DataDirect 7.1 Greenplum ODBC
NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Any of the following:
  • Greenplum Database 4.1, 4.2, 4.3
  • HAWQ
Driver Any of the following:
  • PsqlODBC 9.x
  • DataDirect 7.1 Greenplum ODBC
NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Version: 2.1
Category Requirement
Data Source Any of the following:
  • Greenplum Database 4.1, 4.2, 4.3
  • HAWQ
Driver Any of the following:
  • PsqlODBC 9.x
  • DataDirect 7.1 Greenplum ODBC
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 2.0
Category Requirement
Data Source Any of the following:
  • Greenplum Database 4.1, 4.2, 4.3
  • HAWQ
Driver Any of the following:
  • PsqlODBC 9.x (32 and 64bit)
  • DataDirect 7.1 Greenplum ODBC
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 1.0
Category Requirement
Data Source Any of the following:
  • Greenplum Database 4.1, 4.2
  • HAWQ
Driver Any of the following:
  • PsqlODBC 9.x (32 and 64bit)
  • DataDirect 7.1 Greenplum ODBC
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0


TIBCO Spotfire Connector for Pivotal HAWQ
Version: Spotfire Cloud version
Category Requirement
Data Source Pivotal HD 1.0.7
Driver Any of the following:
  • PsqlODBC 9.x
  • DataDirect 7.1 Greenplum ODBC
NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Pivotal HD 1.0.7
Driver Any of the following:
  • PsqlODBC 9.x
  • DataDirect 7.1 Greenplum ODBC
NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Version: 1.1
Category Requirement
Data Source Pivotal HD 1.0.7
Driver Any of the following:
  • PsqlODBC 9.x (32 and 64bit)
  • DataDirect 7.1 Greenplum ODBC
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 1.0
Category Requirement
Data Source Pivotal HD 1.0.7
Driver Any of the following:
  • PsqlODBC 9.x (32 and 64bit)
  • DataDirect 7.1 Greenplum ODBC
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5


TIBCO Spotfire Connector for PostgreSQL (and Amazon Redshift)
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • PostgreSQL 8.4, 9.0, 9.1, 9.2, 9.3, 9.4
  • Amazon Redshift*
NOTE *: From this version, a new connector - TIBCO Spotfire Connector for Amazon Redshift - should be used for connecting to Amazon Redshift.
Driver psqlODBC 9.x

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
SSL Support Yes
Version: 4.0
Category Requirement
Data Source Any of the following:
  • PostgreSQL 8.4, 9.0, 9.1, 9.2
  • Amazon Redshift*
NOTE *: From this version, a new connector - TIBCO Spotfire Connector for Amazon Redshift - should be used for connecting to Amazon Redshift.
Driver psqlODBC 9.x

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
SSL Support Yes
Version: 3.1
Category Requirement
Data Source Any of the following:
  • PostgreSQL 8.4, 9.0, 9.1, 9.2
  • Amazon Redshift
Driver psqlODBC 9.x

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 3.0
Category Requirement
Data Source Any of the following:
  • PostgreSQL 8.4, 9.0, 9.1, 9.2
Driver psqlODBC 9.x

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 2.0
Category Requirement
Data Source Any of the following:
  • PostgreSQL 8.4, 9.0, 9.1, 9.2
Driver psqlODBC 9.01.02.00

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0
Version: 1.0
Category Requirement
Data Source Any of the following:
  • PostgreSQL 8.4, 9.0, 9.1, 9.2
Driver psqlODBC 9.01.02.00

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 5.5
  • TIBCO Spotfire Web Player 5.5
  • TIBCO Spotfire Automation Services 5.5


TIBCO Spotfire Connector for SAP HANA
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • SAP HANA SPS6 server or later
  • AWS SAP HANA One
Driver SAP HANA ODBC driver 1.00.60.x to 1.00.80.x

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Authentication Methods Username and Password
Kerberos
SSL Support Yes
Version: 4.0
Category Requirement
Data Source Any of the following:
  • SAP HANA SPS6 server or later
  • AWS SAP HANA One
Driver SAP HANA ODBC driver 1.00.60.x to 1.00.80.x

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Authentication Methods Username and Password
Kerberos
SSL Support Yes
Version: 2.1
Category Requirement
Data Source Any of the following:
  • SAP HANA SPS6 server or later
  • AWS SAP HANA One
Driver SAP HANA ODBC driver 1.00.60.x to 1.00.80.x

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 2.0
Category Requirement
Data Source Any of the following:
  • SAP HANA SPS6 server or later
  • AWS SAP HANA One
Driver SAP HANA ODBC driver version 1.00.60.379371

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 1.0
Category Requirement
Data Source Any of the following:
  • SAP HANA SPS6 server or later
  • AWS SAP HANA One
Driver SAP HANA ODBC driver version 1.00.60.379371

NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0


TIBCO Spotfire Connector for SAP NetWeaver Business Warehouse
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • SAP NetWeaver Business Warehouse 7.01 SP10, 7.3
Driver Any of the following:
  • SAP BW OLE DB for OLAP provider

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Any of the following:
  • SAP NetWeaver Business Warehouse 7.01 SP10, 7.3
Driver Any of the following:
  • SAP BW OLE DB for OLAP provider

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Version: 3.1
Category Requirement
Data Source Any of the following:
  • SAP NetWeaver Business Warehouse 7.01 SP10, 7.3
Driver Any of the following:
  • 32 bit: SAP BW OLE DB for OLAP provider
  • 64 bit: SAP BW OLE DB for OLAP provider 64bit

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 3.0
Category Requirement
Data Source Any of the following:
  • SAP NetWeaver Business Warehouse 7.01 SP10, 7.3
Driver Any of the following:
  • 32 bit: SAP BW OLE DB for OLAP provider
  • 64 bit: SAP BW OLE DB for OLAP provider 64bit

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 2.0
Category Requirement
Data Source Any of the following:
  • SAP NetWeaver Business Warehouse 7.01 SP10, 7.3
Driver Any of the following:
  • 32 bit: SAP BW OLE DB for OLAP provider
  • 64 bit: SAP BW OLE DB for OLAP provider 64bit

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0
Version: 1.0
Category Requirement
Data Source Any of the following:
  • SAP NetWeaver Business Warehouse 7.01 SP10
Driver Any of the following:
  • 32 bit: SAP BW OLE DB for OLAP provider
  • 64 bit: SAP BW OLE DB for OLAP provider 64bit

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 5.5
  • TIBCO Spotfire Web Player 5.5
  • TIBCO Spotfire Automation Services 5.5


TIBCO Spotfire Connector for Teradata
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • Teradata 13.00, 13.10, 14.00, 14.10, 15.00
Driver Any of the following:
  • .NET Data Provider for Teradata, version 13.11.00.01
  • .NET Data Provider for Teradata, version 14.00.00.00
  • .NET Data Provider for Teradata, version 14.10.00.00
  • .NET Data Provider for Teradata, version 15.00.00.00

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Any of the following:
  • Teradata 13.00, 13.10, 14.00, 14.10, 15.00
Driver Any of the following:
  • .NET Data Provider for Teradata, version 13.11.00.01
  • .NET Data Provider for Teradata, version 14.00.00.00
  • .NET Data Provider for Teradata, version 14.10.00.00
  • .NET Data Provider for Teradata, version 15.00.00.00

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x
Version: 3.1
Category Requirement
Data Source Any of the following:
  • Teradata 12.00.02, 13.00, 13.10, 14.00, 14.10, 15.00
Driver Any of the following:
  • .NET Data Provider for Teradata, version 13.11.00.01
  • .NET Data Provider for Teradata, version 14.00.00.00
  • .NET Data Provider for Teradata, version 14.10.00.00
  • .NET Data Provider for Teradata, version 15.00.00.00

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 3.0
Category Requirement
Data Source Any of the following:
  • Teradata 12.00.02, 13.00, 13.10, 14.00, 14.10, 15.00
Driver Any of the following:
  • .NET Data Provider for Teradata, version 13.11.00.01
  • .NET Data Provider for Teradata, version 14.00.00.00
  • .NET Data Provider for Teradata, version 14.10.00.00
  • .NET Data Provider for Teradata, version 15.00.00.00

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 2.0
Category Requirement
Data Source Any of the following:
  • Teradata 12.00.02, 13.00, 13.10, 14.00, 14.10
Driver Any of the following:
  • .NET Data Provider for Teradata, version 13.11.00.01
  • .NET Data Provider for Teradata, version 14.00.00.00
  • .NET Data Provider for Teradata, version 14.10.00.00

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0
Version: 1.0
Category Requirement
Data Source Any of the following:
  • Teradata 12.00.02, 13.00, 13.10, 14.00, 14.10
Driver
  • .NET Data Provider for Teradata, version 13.11.00.01
  • .NET Data Provider for Teradata, version 14.00.00.00
  • .NET Data Provider for Teradata, version 14.10.00.00

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 5.5
  • TIBCO Spotfire Web Player 5.5
  • TIBCO Spotfire Automation Services 5.5


TIBCO Spotfire Connector for Teradata Aster
Version: Spotfire Cloud version
Category Requirement
Data Source Any of the following:
  • Teradata Aster 5.0, 5.11, 6.0
Driver Any of the following:
  • Aster ODBC Driver 6.0 or higher

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
NOTE: Make sure you download the latest released version of the Aster ODBC driver (e.g. included in the "Client Tools" package provided by Teradata). Note that the driver is currently not available in each new version of the "Client Tools" package - if you encounter this issue, please look for it in a previous version.
TIBCO Spotfire Software TIBCO Spotfire Cloud Installed Client
Version: 4.0
Category Requirement
Data Source Any of the following:
  • Teradata Aster 5.0, 5.11, 6.0
Driver Any of the following:
  • Aster ODBC Driver 6.0 or higher

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
NOTE: Make sure you download the latest released version of the Aster ODBC driver (e.g. included in the "Client Tools" package provided by Teradata). Note that the driver is currently not available in each new version of the "Client Tools" package - if you encounter this issue, please look for it in a previous version.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Installed Client (Professional/Enterprise Player/Analyst/Desktop) 7.0.x
  • TIBCO Spotfire Web Player 7.0.x
  • TIBCO Spotfire Automation Services 7.0.x

NOTE: TIBCO Spotfire Connector for Teradata Aster version 4.0 is not compatible with previous connector versions. Existing analysis files using previous connector versions need to be updated to use the new version.
Version: 3.1
Category Requirement
Data Source Any of the following:
  • Teradata Aster 5.0, 5.11, 6.0
Driver Any of the following:
  • Aster ODBC Driver 6.0 or higher

NOTE: 64-bit versions only
NOTE: The driver must be installed on the machine running the data connector
NOTE: Make sure you download the latest released version of the Aster ODBC driver (e.g. included in the "Client Tools" package provided by Teradata). Note that the driver is currently not available in each new version of the "Client Tools" package - if you encounter this issue, please look for it in a previous version.
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Web Player 6.5.x (6.5.1 or higher)
  • TIBCO Spotfire Automation Services 6.5.x (6.5.1 or higher)
Version: 3.0
Category Requirement
Data Source Any of the following:
  • Teradata Aster 5.0, 5.11, 6.0
Driver Any of the following:
  • Aster Database ADO.NET Provider (x86) 5.0.2
  • Aster Database ADO.NET Provider (x64) 5.0.2

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.5
  • TIBCO Spotfire Web Player 6.5
  • TIBCO Spotfire Automation Services 6.5
Version: 2.0
Category Requirement
Data Source Any of the following:
  • Teradata Aster 5.0, 5.11
Driver Any of the following:
  • Aster Database ADO.NET Provider (x86) 5.0.2
  • Aster Database ADO.NET Provider (x64) 5.0.2

The driver must be installed on the machine running the data connector
TIBCO Spotfire Software Any of the following:
  • TIBCO Spotfire Professional 6.0
  • TIBCO Spotfire Web Player 6.0
  • TIBCO Spotfire Automation Services 6.0