TIBCO Spotfire Server System Requirements - v4.5.x

To view the System requirements for a different version, please select it in the list below:


TIBCO Spotfire Server 4.5.x
Category Requirement
Operating System Microsoft Windows Server 2008 R2
Microsoft Windows Server 2008 R2 Hyper-V
Microsoft Windows Server 2008
Microsoft Windows Server 2003 R2 SP2 *

Oracle (Sun) Solaris 10 *
Oracle (Sun) Solaris 9 *

Red Hat Enterprise Linux 6
Red Hat Enterprise Linux 5

SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server 10


NOTE: All operating systems must be installed by the customer prior to Spotfire software installation.

NOTE: Both 32- and 64-bit versions of the Operating Systems are supported.

NOTE: * Will not be supported in future releases.
Processor For Windows: Intel Pentium 4 or equivalent, 2 GHz or higher
For Oracle Solaris: UltraSparc IIIi or equivalent, 1 GHz or higher
For Linux: Intel Pentium 4 or equivalent, 2 GHz or higher
RAM 4 GB recommended (2 GB minimum)
Hard disk space 1 GB of free space to complete installation
500 MB for base server software to execute
Recommended 10 GB or greater when TIBCO Spotfire Server 4.5.x is configured with database on the same machine.
Spotfire Server Database Oracle:
    Oracle11g  Release 2 (11.2.0.x)
    Oracle11g  Release 1 (11.1.0.x)
    Oracle10g  Release 2 (10.2.0.x)
    Oracle10g  Release 1 (10.1.0.x)

    Oracle10g XE (Not recommended - for non-production environments only **)

Microsoft SQL Server:
    Microsoft SQL Server 2008 R2(Datacenter, Parallel Data Warehouse, Enterprise, Standard, Workgroup, Express, Developer)
    Microsoft SQL Server 2008 (Enterprise, Standard, Workgroup, Express, Developer)
    Microsoft SQL Server 2005 SP2 and higher (Enterprise, Standard, Workgroup, Express, Developer)


NOTE: ** Oracle10g XE is supported for use in non-production environments (like evaluation, test or development) but for production environments, Spotfire strongly recommends using one of the recommended database engines listed above.
Please note that there are numerous known limitations when using Oracle XE instead of one of the recommended database types, such as:
  • a 4GB limit is enforced on disk space (which will e.g. limit the amount of data that can be stored in the Spotfire Library)
  • it can only address 1GB of RAM
  • it can only use one CPU
  • Oracle bugs that can cause Spotfire server migrations to fail (workaround documented in manual)
  • Spotfire Server startup issues after reboot when Oracle XE is installed on the same machine (caused by Oracle TNS Listener). It is recommended to install Oracle XE on a separate machine

NOTE: Please note that the Oracle or Microsoft SQL Server database is third-party software that must be installed by the customer prior to the Spotfire software installation.

NOTE: The TIBCO Spotfire Server installation requires two database schemas to be created. These schemas together require minimum 512 MB - there is no upper limit for the size, unless restricted by database limitations.
Tested Information Services Data Sources Oracle11g  Release 2 (11.2.0.x) on Oracle Exadata Database Machine
Oracle11g  Release 2 (11.2.0.x)
Oracle11g  Release 1 (11.1.0.x)
Oracle10g  Release 2 (10.2.0.x)
Oracle10g  Release 1 (10.1.0.x)
Oracle10g  XE
Oracle9i  Release 2 (9.2.0.x)

Microsoft SQL Server 2008 R2
Microsoft SQL Server 2008
Microsoft SQL Server 2005 SP2 and higher
Microsoft SQL Server 2000

Teradata 13.0 and higher
SAP HANA
MySQL 5.x
DB2 8.1.2.169
DB2 9.x
Sybase ASE 15.0 Express

TIBCO Spotfire Advanced Data Services

NOTE: Please note that the databases are third-party software - not bundled with the Spotfire software installation.
Tested JDBC Drivers Oracle:
    Oracle 11g Release 1 JDBC Thin Driver, ojdbc6.jar for use with JDK 1.6
    DataDirect v4.1 Oracle JDBC Driver

Microsoft SQL Server:
    Microsoft SQL Server JDBC Driver 3.0
    jTDS v1.2.5

Teradata:
    Teradata JDBC Driver 13.10.00.31

SAP HANA:
    SAP HANA JDBC Driver

MySQL:
    MySQL Connector/J 5.1

DB2:
    IBM Data Server Driver for JDBC and SQLJ, version 3.50.152

Sybase:
    Sybase JConnect, version 6.05
    jTDS v1.2.5
TIBCO Spotfire Software TIBCO Spotfire Server 4.5.x, with a TIBCO Spotfire 4.5.x deployment, supports connections from TIBCO Spotfire (Client), TIBCO Spotfire Web Player and TIBCO Spotfire Automation Services version 4.5.x.

Upgrades:
TIBCO Spotfire Clients of version 3.2.x to 4.5.x can connect to TIBCO Spotfire Server 4.5.x (with a TIBCO Spotfire 4.5.x deployment) to be upgraded to TIBCO Spotfire 4.5.x.
Authentication Method One of following:
    LDAP (Microsoft Active Directory, Oracle (Sun) Java System Directory Server)
    Kerberos v5 for Active Directory
    NTLMv1 and NTLMv2
    Microsoft Windows NT Domain
    Database Table (Spotfire Server used to both manage and store usernames and passwords)
    Custom JAAS modules using username/password credentials
    X.509 client certificates (limited to one certificate per CA per Windows profile)
Installation Privileges on Windows TIBCO Spotfire Server 4.5.x must be installed under a Windows user account with full administrative privileges.
Locale The server should run in an English (United States) language setting.
Administration Client Web Browser Microsoft Internet Explorer 7.0.x to 9.0.x
Mozilla Firefox 7.0.x and higher
Google Chrome 14.0.x and higher
Network IPv4 or IPv6
VMWare (Optional) TIBCO Spotfire Server can be run on VMWare Server 3.0 and higher
Load Balancer (Optional) Load balancing Spotfire Servers can be achieved using Apache httpd with the mod_jk module enabled. This solution is fully tested (using Apache httpd v2.2.14 and mod_jk v1.2.28) and recommended. It is also possible to use a different load balancing solution, as long as it supports session affinity, which ensures that a client communicates with the same server for the duration of the session.